System requirements 

Abstract

Overview of the system requirements for the Sitecore XC solution.

The following table lists the software required for your Sitecore XC solution.

Operating system

Windows Server 2016

Windows 10 Professional (32/64-bit)

.NET Framework 4.7.1 Developer Pack (including available updates)

ASP.NET MVC 5.2 or later

ASP.NET Core 2.0

.NET Core Windows Server Hosting 2.0.0

OData 7.2.0

Database

Microsoft SQL Server 2016 SP1

Note

Sitecore XP 9.0, specifically Experience Database (xDB), does not support other SQL versions, and does not support MongoDB and Oracle.

Web server

IIS 10.0 or IIS 8.5 (the version supported by your operating system)

Microsoft Web Deploy 3.6

URL Rewriter

Development

Visual Studio 2017

.NET Core 2.0.0 Visual Studio 2017 Tooling

MSBuild Microsoft Visual Studio Web targets (available from Nuget)

Git client

Deployment

PowerShell 5.1 or later

Node.js

OData Connected Service (available from Visual Studio Marketplace)

Search indexing

Solr 7.2.1

Sitecore software

Sitecore Experience Platform 9.1 Update-1 (available on dev.sitecore.net)

Sitecore Experience Accelerator 1.8.1 (available on dev.sitecore.net)

Sitecore PowerShell Extensions 4.7.2 (available from the Sitecore Marketplace)